1984 chevy pickup 350 sputters when taking off

Reply

  #1  
Old 05-23-09, 07:14 PM
Member
Thread Starter
Join Date: May 2009
Location: southeast US
Posts: 7
Question 1984 chevy pickup 350 sputters when taking off

350 engine. I have changed spark plugs and wires, distributor, module, rotary, gas filter with no help. Engine lacks power when starting off but runs good after getting up to speed. Just sputters like a tractor at low speeds and runs rough. Any help would be appreciated.
 
Sponsored Links
  #2  
Old 05-24-09, 04:06 PM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,595
Is that carbureted or fuel injected?
 
  #3  
Old 05-27-09, 08:42 AM
Member
Thread Starter
Join Date: May 2009
Location: southeast US
Posts: 7
carbuator. Think it may be the carb?
 
  #4  
Old 06-02-09, 08:41 AM
Join Date: Jan 2007
Location: North Central Indiana
Posts: 912
sputters taking off

Possible causes, Acc pump in carb, vac leak, heat riser stuck.
 
  #5  
Old 06-02-09, 09:10 AM
Gunguy45's Avatar
Super Moderator
Join Date: Dec 2007
Location: USA
Posts: 21,030
I was thinking accelerator pump as well...if its just when you are accelerating...if it does it at constant low speeds..then one of the other things.

Should be pretty easy to check IIRC, just pop the air cleaner...work the throttle and look for a squirt of fuel in the throat. You'll need to hold the butterfly/choke plate open.
At least thats the way I used to check mine...course that was about 20 yrs ago last I had a carb on a vehicle.

How does it do if you "feather" the throttle when taking off?
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes