1995 Toyota Tacoma 2.4 hard start

Reply

  #1  
Old 08-16-09, 06:43 PM
Member
Thread Starter
Join Date: Aug 2009
Location: Jackson, MS
Posts: 1
1995 Toyota Tacoma 2.4 hard start

I have 1995 Toyota Tacoma 2.4 very hard to start after it warms up and sits for a few minutes. I have changed out fuel filter, fuel pump, fuel regulator, plugs, wires, dist. cap, rotar button. I had the ignition module check, it was Ok. It cranks right up when engine is cold, but after you drive and park it for 10-15 minutes and then try to crank it is very difficult to start. HELP!!!! I was told it could be ignition coil but I don't know how to check it. Any suggestions will be very appreciated. Thanks
 
Sponsored Links
  #2  
Old 08-16-09, 07:07 PM
Member
Join Date: Feb 2009
Location: USA
Posts: 323
When did you get the hard start?

After you replaced what, did the hard start begin, or did it begin the symptoms and you replaced everything. Give us a detailed sequence of events from the first thing you replaced and when exactly the hard start began.
 
  #3  
Old 08-16-09, 07:53 PM
Member
Join Date: May 2006
Location: Iowa!!!!!
Posts: 3,687
I wouldn't have changed the pump and regulator until you had a pressure check on the rail that pointed toward a fault in the fuel system.

The ignition components and fuel filter could be be written off as normal maintenance items, though.

I would say the coil could be suspect if you're getting a no start, but my first thoughts would be a leaking at the injectors. This would be especially if you could get it started and it ran reasonably well.
 
  #4  
Old 08-17-09, 06:25 PM
Member
Join Date: Feb 2009
Location: USA
Posts: 323
Also how many miles on it? Whenever I hear of a driveability prob I either recommend or use it myself.....BG44K. Get it at any dealership and drive it for a tank and see what happens.

I've seen this stuff clean up some pretty rough running engines.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'