Dakota MAP sensor fouling

Reply

  #1  
Old 09-17-09, 04:26 PM
Member
Thread Starter
Join Date: Feb 2005
Location: Frozen Tundra, WI
Posts: 304
Dakota MAP sensor fouling

I have been getting a MAP sensor trouble code and it causes the truck to run rough. It is a 2000 Dakota with a 4.7L. When I get the light, I remove the sensor, clean it, replace it, and it works fine for about 2 weeks, then it repeats.

When I pull it, there is what appears to be some oil on the sensor, which I would assume would be expected to some degree (the truck goes through very little oil, so it can't be excessive blow by).

It may just be that the sensor is failing and any little contamination fouls it, but I would not think that to be the case. Any ideas which way to go? I do not want to shell out the cash if the MAP is only the symptom and not the problem.

Thanks,
 
Sponsored Links
  #2  
Old 09-22-09, 01:12 PM
Member
Thread Starter
Join Date: Feb 2005
Location: Frozen Tundra, WI
Posts: 304
What has happenned to this site? It used to be when a question was posted, a 1000 people would answer. Now it is dead with very little response.

Anyhow, I found the problem (holding off cost me a new MAP). Even though the PCV valve sounded like it was ok, there must have been some blow by. Once I replaced it, the MAP stayed clean. Unfortunately, when I cleaned the MAP for the umteenth time, it must have done it in, because it ran horribly. I replaced the MAP and all runs fine now.
 
  #3  
Old 09-22-09, 02:39 PM
Gunguy45's Avatar
Super Moderator
Join Date: Dec 2007
Location: USA
Posts: 20,922
Dave....
I think it gets so much action that posts get bumped off very quickly. I know I usually use the new posts tab to check.

And some folks got fed up with the spammers and problems with posting and they finally took a vacation from replying...

Glad you got it fixed!
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'