89 Mazda B2200 won't start.

Reply

  #1  
Old 10-14-09, 08:51 PM
Member
Thread Starter
Join Date: Sep 2009
Location: cedar rapids ia
Posts: 25
Unhappy 89 Mazda B2200 won't start.

I have a new problem. I just bought this truck, I just replaced the clutch first and tune up. plugs,wires,cap&roter,fule filter,ect.... and I cleaned the carburetor last. I have not driven this truck since I started working on it. I put everything back together and started the truck and it ran for about 30 seconds at high Idle so gave it some gas and it sputtered and died, and now it won't start. I'm thinking I got some vac hoses mix up. anyone know where I can get a good diagram of the connections of vac hoses?

Question: with the car off, looking down at the carburetor, I was engaging the gas(throttle cable?) but I didn't see any gas coming out; is that the problem? wouldn't I be able to see gas squirting out? cuz I didn't.
 
Sponsored Links
  #2  
Old 10-15-09, 05:16 AM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,525
Yes, if you look down the carburetor throat while you pump the gas you should see the accellerator pump squirting gas. My guess is your carburetor bowl is empty, i.e. you have a fuel delivery problem. Fuel filter or fuel pump likely I would think.

Check autozone.com for diagrams; you'll have to register & log in, but they have some pretty good repair data.
 
  #3  
Old 10-15-09, 02:49 PM
Member
Thread Starter
Join Date: Sep 2009
Location: cedar rapids ia
Posts: 25
[QUOTE=the_tow_guy;1634849]Yes, if you look down the carburetor throat while you pump the gas you should see the accellerator pump squirting gas. My guess is your carburetor bowl is empty, i.e. you have a fuel delivery problem. Fuel filter or fuel pump likely I would think.

Check autozone.com for diagrams; you'll have to register & log in, but they have some pretty good repair data.[/QU
 

Last edited by sphinxx187; 10-15-09 at 04:39 PM.
  #4  
Old 10-15-09, 04:40 PM
Member
Thread Starter
Join Date: Sep 2009
Location: cedar rapids ia
Posts: 25
I'm getting smoke

went out and took the air cover off and looked around and I missed a vacuum hose, it just need to be plugged off. hooked the battery back up and fired up. now I'm getting a lot smoke from three hoses that connects onto the air cleaner assembly (air return?) I let it ran for about minute and shut it off. felt inside the 3 hoses and it was wet, not sure if it was oil or gas. I did just cleaned the carburetor, would that make it smoke?
 
  #5  
Old 10-15-09, 06:32 PM
Member
Join Date: May 2006
Location: Iowa!!!!!
Posts: 3,684
Make sure your oil is at the right level, then let it run a while. The smoke should clear up.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'