94 nissan truck help needed

Reply

  #1  
Old 11-16-09, 01:21 PM
Member
Thread Starter
Join Date: Sep 2004
Location: usa
Posts: 221
Received 0 Votes on 0 Posts
94 nissan truck help needed

94 nissan, 5 speed, v6. truck starts fine, runs good for about 15-20 minutes, then it starts to spit and sputter and finally stall out. All i have to do is pull the fuel line off after the fuel filter, which relieves pressure, then put it back together and I am fine for another 15-20 minutes. I changed the fuel filter but no help.

ANy ideas to what I should look for.
 
Sponsored Links
  #2  
Old 11-16-09, 01:34 PM
Member
Join Date: Sep 2009
Location: USA
Posts: 497
Received 0 Votes on 0 Posts
When you say "relieve pressure" do you mean that gas comes out or air is sucked in?

If gas comes out, you probably have a blockage in the fuel return hose that returns fuel to the tank.

If air goes in, you may have a bad fuel cap. It can't draw enough to collapse the tank so you basically run out of fuel. You open the system, air goes in, and fuel flows -- again.
 
  #3  
Old 11-17-09, 12:05 PM
Member
Thread Starter
Join Date: Sep 2004
Location: usa
Posts: 221
Received 0 Votes on 0 Posts
nissan

gas sprays out. I blew air thru the return hose already with the gas cap off and can hear the air coming out.
 
  #4  
Old 11-17-09, 12:58 PM
Gunguy45's Avatar
Super Moderator
Join Date: Dec 2007
Location: USA
Posts: 21,107
Received 0 Votes on 0 Posts
Try driving w/o the gas cap for a while and see if it does the same thing. Or just loosen it to prevent any possible splashing. Not something I'd normally recommend..but why buy a new cap until you know for sure.
 
  #5  
Old 11-17-09, 02:09 PM
Member
Join Date: Sep 2009
Location: USA
Posts: 497
Received 0 Votes on 0 Posts
There must be a fuel pressure regulator in the system. It may have failed or become intermittent. Some pressure is normal in the system, it could be up to about 40psi, I don't have the specs for your truck.

Can you tap in a fuel pressure gauge for a bit and see what happens when it stalls out?
 
  #6  
Old 11-17-09, 06:42 PM
Member
Thread Starter
Join Date: Sep 2004
Location: usa
Posts: 221
Received 0 Votes on 0 Posts
nissan

I was going to try to put a guage in it, the fuel pump is only about 1 year old.

I talked to a guy at work today, this happened to his toyota, what he said it was was when the gas companies in the area chenged over to winter bled gas, he just ran out and put fresh gas in it. I got about 1/4 tank left.
 
  #7  
Old 11-19-09, 02:23 PM
Member
Thread Starter
Join Date: Sep 2004
Location: usa
Posts: 221
Received 0 Votes on 0 Posts
nissan

I didnt get to try the fuel guage yet.
I did try
Try driving w/o the gas cap for a while and see if it does the same thing. Or just loosen it to prevent any possible splashing. Not something I'd normally recommend..but why buy a new cap until you know for sure.
Did the same this with cap loose. Worse at higher rpms
 
  #8  
Old 11-19-09, 03:29 PM
Member
Join Date: May 2006
Location: Iowa!!!!!
Posts: 3,955
Received 3 Votes on 3 Posts
The winter blend fuel shouldn't cause that. Winter fuel will vaporize more readily at a lower temperature. That will sometimes cause problems when you have winter fuel at the start of summer. Then the fuel vaporizes in the rail and causes running problems right after startup in hot weather.

From what you've described, it could be the regulator. A good place to start would be with a pressure test.
 
  #9  
Old 11-20-09, 12:06 PM
Member
Thread Starter
Join Date: Sep 2004
Location: usa
Posts: 221
Received 0 Votes on 0 Posts
nissan

I did a pressure test.
WHen I turn the key on the pressure jumps to about 45 psi.
Shut the key off it will drop not fast but quicker than I remember in the past.
When I start it it drops to about 35 psi. I took it for a ride with the guage, as soon as it starts to sputter the pressure drops to almost nothing.

Does this sound like a pump or regulator?
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description: