Suburban furnaces won't work

Reply

  #1  
Old 09-28-10, 08:50 PM
sherylannj1's Avatar
Member
Thread Starter
Join Date: Sep 2010
Location: USA
Posts: 1
Question Suburban furnaces won't work

I have recently purchased an 89 Allegro bay Motor Home. I have turned on gas, turned gas on to furnaces (has two), battery charged and working, set thermos, switched on and nothing happens. I am 61 yr old widow, need someone to give me some ideas on what to do. Be nice! lol
 
Sponsored Links
  #2  
Old 10-23-10, 06:06 AM
Member
Join Date: Jan 2006
Location: Ontario, Canada
Posts: 759
DO you have any knowledge, or friends who could maybe check for voltage, or thermostat, or anything else yet? Does furnace even come on, but blow cold? No noises at all?
 
  #3  
Old 10-23-10, 10:11 AM
GregH's Avatar
Super Moderator
Join Date: Jan 2001
Location: Manitoba
Posts: 9,766
Talking Welcome to our forums!................We are always nice.

It is likely that your furnace has a pilot light.

There should be instructions on the furnace somewhere.
You usually, turn on the gas, turn the gas valve to the pilot position, push the knob in to get gas to the pilot assembly while holding a lit match there.
When the pilot lights keep holding the button for a minute or so and release.
If the pilot remains lit, turn the gas valve to the on position.

On the other hand if you have a completely automatic furnace you would then do well to have someone familiar with these furnaces help.
 
  #4  
Old 10-25-10, 05:02 AM
Member
Join Date: Jan 2006
Location: Ontario, Canada
Posts: 759
Hey,Greg.H, -This is a motorhome, it will be an RV style furnace with automatic ignition. Your going to confuse the lady.
 
  #5  
Old 10-25-10, 05:06 AM
Member
Join Date: Jan 2006
Location: Ontario, Canada
Posts: 759
Seeing how motorhome is new to you, it could be as simple as battery disconnect not on for coach , which supplies power . Are you having any luck yet?
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes