windshield wipers on '98 Chevy C1500 P/U

Reply

  #1  
Old 01-13-11, 07:14 AM
D
Member
Thread Starter
Join Date: Jan 2011
Location: U.S.A.
Posts: 2
Received 0 Votes on 0 Posts
windshield wipers on '98 Chevy C1500 P/U

Came home in a snow storm yesterday and had to stop several times to clear the windshield of ice. Each time I shut the wipers off. About the third time I stopped, cleared the windshield, got back in and the wipers were on! I checked the switch and it was off! Now I have to pull the fuse to shut the wipers off. What is causing this? Is it a short somewhere? Any help with this would be greatly appreciated. Thanks.
 
Sponsored Links
  #2  
Old 01-15-11, 04:22 AM
2
Member
Join Date: Nov 2010
Location: usa
Posts: 15
Received 0 Votes on 0 Posts
If you disconnect the switch harness under the dash and they still run you have a shorted motor. If they quit running you have a bad switch.
 
  #3  
Old 01-24-11, 09:41 AM
D
Member
Thread Starter
Join Date: Jan 2011
Location: U.S.A.
Posts: 2
Received 0 Votes on 0 Posts
OK, thanks, I'll try that.
 
  #4  
Old 02-05-11, 10:37 PM
J
Banned. Rule And/Or Policy Violation
Join Date: Jul 2010
Location: US
Posts: 136
Received 0 Votes on 0 Posts
Check for moisture inside the wiper motor under the cover where the wiring harness plugs in.
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: