Chevy LUV PROBLEM!!!!! HELP PLEASE!!!!!!

Reply

  #1  
Old 05-06-11, 07:51 PM
Member
Thread Starter
Join Date: May 2011
Location: USA
Posts: 3
Chevy LUV PROBLEM!!!!! HELP PLEASE!!!!!!

I have a 1981 Chevy Luv The motor is from a 1979 Luv, I installed a New 1981 Luv Distributor also a brand new coil. I wired then according to the manual but no matter what I do I cant get a Spark, my power Wire goes to the coil, ground wire to the red wire on the distributor, white wire from distributor to ground. new coil, new distributor, new pickup coil, new cap and rotor. and I cant get spark anywhere. Any information would be appreciated.
 
Sponsored Links
  #2  
Old 05-07-11, 06:13 AM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,589
I'm guessing this is a points & condensor distributor? Couple of dumb questions probably:

1. The distributor is rotating?
2. The points are properly adjusted?

Other than that I would be double checking the circuit for a bad connection, either voltage to the coil or an open somewhere in the distributor/ground circuit. Coil could be dead, of course, but that's probably less likely.
 
  #3  
Old 05-07-11, 09:52 AM
Member
Thread Starter
Join Date: May 2011
Location: USA
Posts: 3
ill repeat

the 79 motor was points but but in 81 chevy luv went to hei which is the only difference between the 2 engines i just bought a brand new and installed an HEI distributor into the 79 motor which is in my 81 body. in reference to ur questions yes the distributor is turning and and as far as voltage goes i am running 12 volts to the coil from the ignition the from what i understand the ground from the coil goes to the distributor, distributor to ground if someone knows a different way for it to be wired or knows more about i wld luv to hear it btw ty tow guy for your input i appreciate the chance to rattle the rocks in my brain
 
  #4  
Old 05-07-11, 10:47 AM
Member
Join Date: Feb 2006
Location: USA
Posts: 6,444
Spark

Why would you ground the distributor? You want the spark to get to the spark plugs.
 
  #5  
Old 05-10-11, 08:37 PM
Member
Thread Starter
Join Date: May 2011
Location: USA
Posts: 3
I tried everything Else but got no spark at all Do you know of a way to Wire it that would help???
 
  #6  
Old 05-11-11, 06:50 AM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,589
I think you've missed something in the circuitry. I don't think you can just drop an HEI into the engine and connect the wires, but I've never tried that so maybe....

Wirepuller, the reference to grounding was to what an ignition circuit used to look like; the positive terminal on the coil would be 12 volts and the negative terminal ran to the distributor (points) to do the open and close thing and fire the coil. I don't know that an HEI doesn't maybe require some minor change in circuitry to work. Hopefully we'll get some help on the subject.

When I'm out and about today, I'll ask around for opinions from the mechanics.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes