Idle goes up and down.......

Reply

  #1  
Old 12-03-11, 02:36 PM
Member
Thread Starter
Join Date: Sep 2004
Location: New York
Posts: 390
Idle goes up and down.......

I just put a brand new 5.4 motor in my 2002 Ford F-350. I started it up and can't keep the idle running smooth, it keeps going up and down, up and down. I can't figure out what the problem is, any ideas? Also this truck has been just sitting for over a year with 3/4's of a fuel tank, would this have anything to do with my problem? Thanks......
 
Sponsored Links
  #2  
Old 12-04-11, 08:43 PM
Member
Join Date: Mar 2009
Location: Texas
Posts: 1,051
Just some thought starters. Can you confirm that all sensor connections were checked and confirmed? Did you also check the OBD2 diagnostics for any codes popping up? Are you certain that the software in the ECM in the truck now matches the engine you installed perfectly? There maybe some level of re-flash required. Was it a new Ford OEM stock motor or something else? I don't think that stale gas is behind this.
 
  #3  
Old 01-01-12, 08:01 AM
Member
Thread Starter
Join Date: Sep 2004
Location: New York
Posts: 390
Well I tried everything, new IAC sensor, PCV, cleaned the Ram air sensor, new battery, nothing worked. I took it into the ford dealer and after $500.00 later they found out that I had a bad 02sensor and a bad injector, Truck runs great now, only thing is I have no money left to go anywhere. The 02sensor corrected the idle problem and the injector corrected the miss i was getting every so often. Just want to let you know in case anyone else ever posts an idle problem on here.... thanks....
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'