Problems with trailer lights.

Reply

  #1  
Old 10-09-13, 04:24 PM
Member
Thread Starter
Join Date: Oct 2013
Location: USA
Posts: 2
Problems with trailer lights.

Hello, I know others have posted problems with trailer lights but could not find anything like my problem. So here go's i bought a trailer the wiring needed to be completely replaced, So i looked up the plug first which is a 6 pin round plug. Then i looked up a trailer wiring diagram and it said to run green and brown wire down right side of trailer. Then run brown wire and Yellow wire down left side of trailer. Hook white wire up for ground. So this is how i wired it up and i have running lights, brake lights, and when the running lights are on i have both right and left blinkers. How ever when i turn off the running lights and turn on the right side blinker both sides blink anyone have any idea whats causing this.
 
Sponsored Links
  #2  
Old 10-09-13, 04:34 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: NJ - USA
Posts: 43,487
[TABLE]
[TR]
[TD="colspan: 3, align: center"]
ASME Wiring Color Code
[/TD]
[/TR]
[TR]
[TD="align: center"]Terminal Marking[/TD]
[TD="align: center"]Wire Color[/TD]
[TD]Function
[/TD]
[/TR]
[TR]
[TD]GD[/TD]
[TD]White[/TD]
[TD]Ground[/TD]
[/TR]
[TR]
[TD]TM[/TD]
[TD]Brown[/TD]
[TD]Running Lights[/TD]
[/TR]
[TR]
[TD]LT[/TD]
[TD]Yellow[/TD]
[TD]Left turn/brake light
[/TD]
[/TR]
[TR]
[TD]ST[/TD]
[TD]Blue[/TD]
[TD]Brake Control
[/TD]
[/TR]
[TR]
[TD]RT[/TD]
[TD]Green[/TD]
[TD]Right turn/brake light
[/TD]
[/TR]
[TR]
[TD]A (Aux)[/TD]
[TD]Black[/TD]
[TD]Power
[/TD]
[/TR]
[/TABLE]

Welcome to the forums.

Is that the color code you followed ?
You should have the two browns connected on the TM terminal.
Also double check the actual ground on the trailer frame. A poor ground causes a multitude of problems.
 
  #3  
Old 10-09-13, 04:51 PM
Member
Thread Starter
Join Date: Oct 2013
Location: USA
Posts: 2
Yep thats the color code i followed, and everything works fine except for the right blinker with the lights off. Thats when both sides blink. I will check the ground again, i cleaned a spot and put a new terminal on it. Does each light need a ground? It only has 2 wires per light red and black. I figured the lights are grounded to the trailer by the bolts that hold the lights to the trailer? Do i need to run a ground wire to each light some how?
 
  #4  
Old 10-09-13, 05:07 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: NJ - USA
Posts: 43,487
You shouldn't need to run a ground to each light. Make sure where the lights bolt on that they are making a good connection to the trailer.
 
  #5  
Old 12-19-13, 08:10 AM
Member
Join Date: Dec 2013
Location: United States
Posts: 2
I know its been a while but I found this post through google. So I figured I would post to help someone else down the line later. I came across a very useful diagram that really helped me here.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'