1992 GMC won't idle

Reply

  #1  
Old 10-15-13, 08:08 AM
Member
Thread Starter
Join Date: Oct 2013
Location: USA
Posts: 3
1992 GMC won't idle

I have a 1992 GMC pick up that the fuel pump went out on. I replaced the pump but now the truck will only run if you prime it manually and keep it above about 2000 rpm. I have tried a new IAC valve, TPS, the fuel regulator gaskets and diaphragm seem to be in good shape. It gives no codes or check engine light. The new fuel pump is always running whenever the key is turned on. Also I can't find any vacuum leaks. Any ideas as to where to go next? Thanks.
 
Sponsored Links
  #2  
Old 10-15-13, 05:49 PM
Join Date: Jan 2007
Location: North Central Indiana
Posts: 905
Whenever you have a symptom after a procedure you look at the procedure. I would say your pump is not pumping properly. It should only run for a few seconds when the key is turned on. The fact you have to prime it says the pump is not working properly. Did you change the fuel filt?
 
  #3  
Old 10-15-13, 09:38 PM
Member
Thread Starter
Join Date: Oct 2013
Location: USA
Posts: 3
Thanks for responding. Yes I replaced the filter but their is no easy place to put a gauge on it to test for pressure since this has two fuel injectors on top of the throttle body and no fuel rail with a test connector.
 
  #4  
Old 10-16-13, 06:25 AM
Member
Join Date: Jun 2013
Location: usa
Posts: 103
5.7l?key on engine off pump should run for only 2 seconds.....it runs continually?during crank.....is there fuel coming out of the injectors?is this pump hard wired or have connector?they have special tbi adapter for fuel pressure that you remove filter and attach to both fuel lines.....i have one that used twice if you are interested....sell cheap...i dont need.let me know.
 
  #5  
Old 10-16-13, 07:14 AM
Join Date: Jan 2007
Location: North Central Indiana
Posts: 905
You need to check the fuel press. New parts can be defective.
 
  #6  
Old 10-16-13, 05:47 PM
Member
Join Date: Jun 2013
Location: usa
Posts: 103
even if pump was bad....it should only run for 2 seconds when key is turned to on position.....if pump is running continually with key in on position.....means there is a voltage feed to pump when there should not be one.
 
  #7  
Old 10-17-13, 08:26 AM
Member
Thread Starter
Join Date: Oct 2013
Location: USA
Posts: 3
Yes I would be interested, will that fit the GM type filters? I believe different makes are different or are they all the same connector? If you want to contact me directly write to [email protected]
Thanks.
 
  #8  
Old 10-17-13, 07:13 PM
Member
Join Date: Jun 2013
Location: usa
Posts: 103
5.7l?model?key on engine off pump should run for only 2 seconds.....it runs continually?during crank.....is there fuel coming out of the injectors?is this pump hard wired or have connector?

it is a otc 7874.....hooks to both lines after you remove fuel filter.for low pressure tbi.....they make adapters that you can use with a fuel pressure gauge.please answer above questions.I sent you a email.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'