No heat in Chevy Silverado

Reply

  #1  
Old 01-14-15, 04:30 AM
Member
Thread Starter
Join Date: Jan 2015
Location: usa
Posts: 2
No heat in Chevy Silverado

I have a 2004 Chevy Silverado.In the last 3 months my truck will not heat up to full temp.It runs about 170 unless i drive about 10 to 12 miles at 70 MPH.Then it will get up to 210,as soon as i slow down it will drop back down to 170.
9 months ago I put a new crate Motor,Transmission,Radiator,Water pump,Thermostat.
Just last weekend i put a new water pump,Thermostat,sending unit and clutch fan.
I also have blocked off part of my grill with card board.I'm not loosing any anti-freeze
 
Sponsored Links
  #2  
Old 01-14-15, 06:58 AM
Temporarily Suspended
Join Date: Jul 2008
Location: NY
Posts: 10,986
Do you remember what temp thermostat you installed? For example, it sounds like you need a 190 degree thermostat.
 
  #3  
Old 01-14-15, 07:35 AM
Member
Join Date: Jan 2011
Location: US
Posts: 33
Sounds like a thermostat issue. Should be a 190 in that truck. To be positive, go to dealer and get a tstat from them. Should clear up your issues. Just know that you are probably diluting your oil with gas since its staying in open loop mode. Also make sure the temp sensor is not the issue.
 
  #4  
Old 01-14-15, 08:28 AM
Member
Thread Starter
Join Date: Jan 2015
Location: usa
Posts: 2
Thank you for the input.
This is the 2nd thermostat's i put in in the last 3 weeks.(186 deg.)
Nothing has changed.
I don't think it's a temp. sensor because it only blows out warm air when it's running at 170 and when it's up to 210 i have nice hot air
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'