2003 Ford Ranger electrical issue

Reply

  #1  
Old 04-03-17, 07:05 AM
Member
Thread Starter
Join Date: Jan 2017
Location: USA
Posts: 5
2003 Ford Ranger electrical issue

A week or so ago, after pulling my Ranger out of the driveway, notice that the radio would go off and on numerous times. This happened for 10 minutes and about 4 miles of driving. Finally realized that the entire truck was shutting off and on. Then all of a sudden this stopped and the truck ran fine. Parked the truck at work, came out later that evening to drive home & truck ran fine. Truck sat for about 5 days before using again. The truck started up fine and was turning around in driveway, truck stalled and would not restart, would not even turn over. Pulled the battery from the truck, put it on charger for about 1/2 hour and the truck started up fine. The battery is about 6 months old. Anyone with ideas where to look. Truck has not been drive last week due to illness. Thanks for any help!
 
Sponsored Links
  #2  
Old 04-03-17, 08:59 AM
pugsl's Avatar
Forum Topic Moderator
Join Date: Mar 2008
Location: Raleigh, NC
Posts: 7,730
Sounds like a bad battery connection or a loose ground. Check where the ground cable bolts in on frame or block. Look for corrosion under battery cable clamps.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'