08 Nissan Titan won't start

Reply

  #1  
Old 05-05-17, 07:17 PM
masazasm's Avatar
Member
Thread Starter
Join Date: Feb 2009
Location: us
Posts: 109
Received 0 Votes on 0 Posts
08 Nissan Titan won't start

The truck turns over fine, I can hear the fuel pump engage, the 15v fuse is fine. I read that it could be the PCM but could only be changed by a mechanic, is there anything else I can check? Thanks
 
Sponsored Links
  #2  
Old 05-07-17, 07:49 AM
Member
Join Date: Oct 2008
Posts: 1,312
Received 0 Votes on 0 Posts
Fuel, air, spark.

Getting fuel? (Spraying a bit of starting spray into the air intake can help to diagnose this.)

Getting spark? Test for spark - would be in service manual for that specific vehicle.

Clean air intake?
 
  #3  
Old 05-08-17, 05:16 PM
masazasm's Avatar
Member
Thread Starter
Join Date: Feb 2009
Location: us
Posts: 109
Received 0 Votes on 0 Posts
I tested for spark and there was none. I bought a camshaft sensor and a crankshaft sensor, installed them and still no spark. I started checking relays and fuses and they all seem fine.
 
  #4  
Old 05-08-17, 05:20 PM
masazasm's Avatar
Member
Thread Starter
Join Date: Feb 2009
Location: us
Posts: 109
Received 0 Votes on 0 Posts
I also sprayed starting fluid into the air intake just to see and it didn't start
 
  #5  
Old 05-08-17, 05:29 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 53,245
Received 380 Votes on 357 Posts
In most vehicles.... the fuel pump is controlled by the PCM. After turning key to run...... the pump should run for about ten seconds and then shut off.

That's an 2008. It should be an OBD-II vehicle. Have you checked for trouble codes ?
That would be the first place to start.
 
  #6  
Old 05-09-17, 07:47 AM
masazasm's Avatar
Member
Thread Starter
Join Date: Feb 2009
Location: us
Posts: 109
Received 0 Votes on 0 Posts
I rented a code reader and i kept getting a message that I need to check connection it couldn't read anything. I can hear the fuel pump come on.
 
  #7  
Old 05-09-17, 08:00 AM
Member
Join Date: Oct 2008
Posts: 1,312
Received 0 Votes on 0 Posts
Check all your fuses. Modern cars/trucks can have fuses in 3 locations sometimes. Under the hood, inside car driver's side, and inside car passenger side. Other vehicles may have only one fuse box. Where they are located should be in your owner's manual.

Not being able to read codes could mean there is no power to a computer, so possibly a fuse (hopefully just a fuse!)

Best to check with a multimeter and only check one fuse at a time, pull it, test it, replace it, then check the next. If you don't know how to use a multimeter, I would recommend taking the car to a mechanic.
 
  #8  
Old 05-09-17, 03:41 PM
masazasm's Avatar
Member
Thread Starter
Join Date: Feb 2009
Location: us
Posts: 109
Received 0 Votes on 0 Posts
I checked the fuses related to ignition/starter/fuel and all were fine I tested some relays with the multimeter and with gator clips hooked to the battery and listened for the "circuit door" to open and close and they all worked as well. The reading I got on some relays were 16 and on 1 I got a reading of 8. Any way I gave in and towed it to the mechanic this morning. I'll give an update on what he finds.
Thanks for the help! 🍻
 
  #9  
Old 05-10-17, 05:40 PM
masazasm's Avatar
Member
Thread Starter
Join Date: Feb 2009
Location: us
Posts: 109
Received 0 Votes on 0 Posts
Mechanic called today and said it was the ECM. $1200 to fix 😵. PJMAX you said the fuel pump wouldn't come on if the PCM was bad in some vehicles do you know if that's the case in this truck? Is $1200 reasonable for this kind of repair? The cost has to be in the part itself labor can not be that much. I can't find the price anywhere
 
  #10  
Old 05-10-17, 07:20 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 53,245
Received 380 Votes on 357 Posts
I checked further and I'm fairly certain the ECM controls the fuel pump. That's not to say it's bad and the fuel pump section still works.

I did a quick google and I'm seeing ECM's for $200-$400.
There is some programming to be done and it may not be easily accessible.
Look down the list... some interesting articles about ECM/IPDM issues.
google=Nissan+Titan+ecm 08

I've left a link to a similar situation to yours.
IPDM-ER Failure/Replacement 04-06 Titans - Problems and Repairs
 
  #11  
Old 05-11-17, 07:40 AM
masazasm's Avatar
Member
Thread Starter
Join Date: Feb 2009
Location: us
Posts: 109
Received 0 Votes on 0 Posts
Thanks for the links. I saw the recalls on the 04-06 Titans and checked my VIN for any recalls and it showed there​ were​ none. After I posted last I did find some prices and called the dealership this morning and they wanted $680 for the part and $350 to program and install. I'm going to get it towed to a different mechanic and have it double checked. I can't trust this guy.
 
  #12  
Old 05-12-17, 06:17 PM
masazasm's Avatar
Member
Thread Starter
Join Date: Feb 2009
Location: us
Posts: 109
Received 0 Votes on 0 Posts
I have the truck back at the house. I talked to our fleet manager at work and he said that he had a VW with the same problem and he sent the computer to a company and they reflashed it and sent it back and the car started right up. The problem is, he couldn't remember the name of the company he sent it to. I've been searching but can only find company's that will do Ford's, GM, etc.. He thought it might be euro something... Just wanted to post this in case anybody knew which company this is. I'm going to keep on searching. Thanks
 
  #13  
Old 05-20-17, 06:04 AM
masazasm's Avatar
Member
Thread Starter
Join Date: Feb 2009
Location: us
Posts: 109
Received 0 Votes on 0 Posts
Found a company on eBay motors, I sent it on Monday got it back on Thursday plugged it in and the truck sounds great. $169 beats $1200 everyday of the year. 🍻
 
  #14  
Old 05-20-17, 08:07 AM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 53,245
Received 380 Votes on 357 Posts
Wow.... that is excellent news. Thanks for letting us know how you made out.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description: