98 Ranger Won't Go Into Third Gear Until All Warmed Up

Reply

  #1  
Old 05-29-17, 09:52 PM
Yukon Youngun's Avatar
Member
Thread Starter
Join Date: Sep 2005
Location: Missouri
Posts: 154
Received 0 Votes on 0 Posts
98 Ranger Won't Go Into Third Gear Until All Warmed Up

My 98 Ranger (3.0L, 2wd, +OD, 198,000 mi) will not go into third gear until it is all warmed up. It seems to come out of 2nd, but not into 3rd. I feel slight drag, but no real pull. Drive about 5 miles, or let it idle in the drive for ten minutes or so, and it does fine.

Not until 2nd day did it throw a "shift solenoid A" failure.

My retired tranny guy replaced the sol., fluid, filter, pan gasket, did some other basic tests and drove it several days with no issues. Day after I picked it up, started again.

Went back, valve body seal kit and other solenoid, bumped the pressure a bit. Same thing, even a bit worse. It tends to hit 3rd and slip back out until a little more fully warmed up.

Before I go back again, any suggestions for what this might be? I can't afford to have him spend a bunch of time searching. I had him stop after the valve body just for a sanity check.
 
Sponsored Links
  #2  
Old 06-06-17, 03:41 PM
Member
Join Date: Mar 2009
Location: USA
Posts: 685
Received 1 Vote on 1 Post
I am not a tranny guy but I own a 2000 Ranger with 120,000 miles. No trouble with trainny, I would try googling the question. Nothing to loose.
Sid
 
  #3  
Old 06-06-17, 06:41 PM
Member
Join Date: Dec 2005
Location: USA
Posts: 518
Received 11 Votes on 11 Posts
Might give this forum a try there are some pretty smart people on there about these transmissions.
Ford Explorer and Ford Ranger Forums - Serious Explorations
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: