2007 Chevy Silverado: Code P0446 Evap Performance

Reply

  #1  
Old 08-07-18, 09:19 PM
D
Member
Thread Starter
Join Date: Jan 2009
Location: CANADA
Posts: 69
Received 0 Votes on 0 Posts
2007 Chevy Silverado: Code P0446 Evap Performance

Hi, I have 2007 Chevy Silverado 2500HD 6L, new model. Randomly I get a Service Engine Soon warning light code P 0446 "EVAP system poor performence". It usually hapens within first 10 minutes of driving, but not every day. Once I reset it by code reader it won't hapen again all day. Replaced the EVAP vent valve, no joy. Checked the hoses, look ok. Any idea what else could be at fault? Thanks, Danigo
 
Sponsored Links
  #2  
Old 08-08-18, 06:25 AM
W
Member
Join Date: Feb 2006
Location: USA
Posts: 6,709
Received 19 Votes on 18 Posts
  #3  
Old 08-08-18, 07:44 PM
D
Member
Thread Starter
Join Date: Jan 2009
Location: CANADA
Posts: 69
Received 0 Votes on 0 Posts
Thanks for the reply Wirepuller38, it's most likely the problem. I replaced the valve but not the hose with the filter. I'll try that and let you know. The truck was operating off road before I bought it and the filter was sprayed with undercoat so it is possibly partially plugged. Thanks, Danigo
 
  #4  
Old 08-29-18, 08:46 AM
D
Member
Thread Starter
Join Date: Jan 2009
Location: CANADA
Posts: 69
Received 0 Votes on 0 Posts
Hi, so I did the modification per the Bulletin it didn't help. The old hose/filter wasn't plugged anyway. Any other idea? Seems that there is a little leak somewhere since it happens intermitenly.
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: