Rheem Gas Water Heater won't light

Reply

  #1  
Old 05-13-03, 04:52 PM
davek
Visiting Guest
Posts: n/a
Rheem Gas Water Heater won't light

11 year old Rheem Powervent will not light. Blower runs, ignitor glows for approx 20 seconds, clicking sound like the gas valve is opening, 3 seconds later the ignitor goes out, another click, and no flame. Help!!!!!
 
Sponsored Links
  #2  
Old 05-13-03, 05:27 PM
davek
Visiting Guest
Posts: n/a
More Info

Refering to the schematic, I checked the voltage at the valve terminals and I get 16 volts after the ignitor is lit for approx 20 seconds, ignitor goes out, then voltage drops back to zero. Schematic looks like it should be 24 volts??

After it sat for approx 15 minutes, I turned it off and back on, the burner actually lit for a second, then went out. Now same as before. I thought more info would help. Any diagnostic help would be appreciated.
 
  #3  
Old 05-13-03, 08:29 PM
davek
Visiting Guest
Posts: n/a
I think I've got it

I found technical materials on Rheems web site for troubleshooting. The problem appears to be the ignition control unit because when I bypass the IC unit and apply 24 v directly to the gas valve, it fires up. I will know for sure after I replace the IC unit.
 
  #4  
Old 05-24-03, 08:47 AM
davek
Visiting Guest
Posts: n/a
Talking Fixed

For those with similar problem, it was the ignition control module. 68 bucks and it's been running for a week. Thanks for the input.
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: