Replaced sprayer, now no hot wtr press???

Reply

  #1  
Old 12-10-05, 08:57 AM
Member
Thread Starter
Join Date: May 2004
Posts: 65
Received 0 Votes on 0 Posts
Replaced sprayer, now no hot wtr press???

I replaced our side sprayer in our kitchen last night. I shut off the water below the sink, replaced the sprayer, and turned the water back on at the valves. Now, for some reason, the hot water has almost no pressure at the faucet!??? Any ideas out there? I'm only a dumb electrician, but the only thing i can think is that maybe when i turned the hot back on, the valve "stuck" partially shut? I checked both valves, and they're both turned on all the way.
 
Sponsored Links
  #2  
Old 12-10-05, 09:33 AM
majakdragon's Avatar
Member
Join Date: Jul 2003
Location: N.E. Arkansas
Posts: 7,827
Received 0 Votes on 0 Posts
When you turned the water off, something (debris) in the waterline may have broke loose and is plugging the faucet. If it was hot AND cold water with low pressure, I would think it was the aerator on the end of the spout. They have small screens that plug up easily. You may have to remove the handle for the hot water (two handle model) or the cartridge (single handle) to see if there is a clog. If it is a cartridge, make sure you note the orientation (position) as it is removed. They can be installed out of line and will not work. Good luck.
 
  #3  
Old 12-10-05, 09:45 PM
Member
Thread Starter
Join Date: May 2004
Posts: 65
Received 0 Votes on 0 Posts
I'll give it a shot, thanks alot
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description:
Your question will be posted in: