Sulphur smell & grey water

Reply

  #1  
Old 04-18-00, 02:18 PM
Visiting Guest
Posts: n/a
Question

I purchased a house six months ago that has two water heaters, one for the original part of the house (15 years old) and one for the new addition (2 years old).

I immediately noticed from the original part of the house ('old house') that the water was a grey to black color and smelled awful of sulfur when using hot water (water is clear and odor-free when using cold). The 'new house' works fine. Water is clear and odor-free whether hot or cold. Also, water is from a public source, not a well.

I called a plumber who said the water heater was defective and replaced it (it was under home warranty so zero cost to us). Water is clear and odor-free for about a month. Now the problem has returned.

Does anyone have an idea what would cause the water to have a sulfur smell and a grey color only when hot??
 
Sponsored Links
  #2  
Old 04-19-00, 11:20 PM
Member
Join Date: Mar 2000
Location: Arlington, WA
Posts: 9,238
Received 0 Votes on 0 Posts
Post

Got to be the hot water pipes in the old section of the house, or the pipe supplying the water heater. Have that checked out and replaced as needed.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description:
Your question will be posted in: