Help? Did I ruin my DE filter?

Reply

  #1  
Old 06-06-04, 07:37 AM
efontana
Visiting Guest
Posts: n/a
Unhappy Help? Did I ruin my DE filter?

I feel like a moron. When I opened my pool this year (should have hired someone) I hooked up the Pump and Return lines in reverse. I then added
4 lbs of DE and then vacuumed the pool. After I did this I tried to backwash, and noticed pretty much nothing coming out. Then, I realized what I had done, tried to open the filter and take out the skids, but it won't come loose on the top connection, it's jammed on there. So I hosed it out the best I could and then re-hooked up everything (correct this time) and a ton DE and crap blew into the pool. The whole pool bottom is covered in DE dust.

Now what should I do? Vacuum on waste? then re-add DE and all set?

Please help, I bought the filter new last year, I don't want to buy another one.

I'm such an idiot.

Thanks
 
Sponsored Links
  #2  
Old 06-07-04, 06:57 AM
Ed Imeduc's Avatar
Member
Join Date: Aug 2002
Location: Mountain Williams Missouri
Posts: 18,389
Wink

I would just clean the bottom of the pool On filter just like everything was ok. Then let it run and see what the pressure gets up to.Then go to wash. If you think about it. After I clean my filter and get everything back to running I add the DE to the skimmer and put it in that way.


ED
 
  #3  
Old 06-07-04, 10:49 AM
efontana
Visiting Guest
Posts: n/a
Smile Update

Well, after it blew all the DE that was previously in the filter into the pool, covering the entire bottom of the pool in a sort of orange-hue, I sent in the vacuum robot and it ate up all the DE. Now the filter seems fine.

Whew;
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'