Hayward heater pilot light wont stay lit

Reply

  #1  
Old 05-30-07, 08:07 PM
J
Member
Thread Starter
Join Date: May 2007
Posts: 1
Received 0 Votes on 0 Posts
Hayward heater pilot light wont stay lit

I have a Hayward H Series H300 pool heater. The pilot light will light with no problem. The heater will fire up and after 5 minutes it will shut the heater and pilot light off. It started doing this at the end of last season. I fired it up tonight and the problem is still there from last year. Any suggestions on where to start? The heater has worked fine since 1999 when it was a new install. Thanks.

JWLuke.
 
Sponsored Links
  #2  
Old 06-02-07, 02:15 AM
H
Member
Join Date: Jul 2005
Location: New York
Posts: 723
Received 0 Votes on 0 Posts
The heater worked fine since 1999 when it was new? The real question here is how often has it been serviced/cleaned in the last eight years? If the answer is "it hasn't", then have it done. The problem sounds like it may be a clogged heat exchanger causing a limit to trip. It's hard to know for sure with out checking it out.

My recommendation is call a pro. Even though gas heaters burn clean, they still require a little maintenance every now and then.
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: