DE is coming back into the pool

Reply

  #1  
Old 07-15-07, 08:10 AM
jt
jt is offline
New Member
Thread Starter
Join Date: Feb 2000
Posts: 33
Question DE is coming back into the pool

Have a EC50C DE filter. DE is coming back into the pool. Just replace the Diaphragm Gasket (the old one had a 1/4 slit in it) DE is still coming back into the pool. What can I try next.

Thanks,
jt
 
Sponsored Links
  #2  
Old 07-15-07, 08:48 AM
todrut's Avatar
Member
Join Date: Jun 2007
Location: USA
Posts: 1,212
Could be residual de left in tank.. If not then could be the fingers.. If not then could be one of the o-rings on the shaft.

Or it could be that its just not seated properly...
Good luck...
 
  #3  
Old 07-17-07, 12:38 PM
Member
Join Date: Jan 2006
Posts: 6
It's most likely the check valve (Hayward Part# ECX4077B1). The check valve keeps the DE in the filter housing when the system is not running. I had the same exact problem with my EC50C filter leaking DE back into the pool and my filter was only 2 years old. The check valve is nothing more than a "rubber flapper" with a brass weight on the back which swings down when the filter pump is shut-off. Replacing the check valve only takes about 2 mins. 1) Remove the inlet pipe (running from the pump to the filter). 2) Pull out the flow restrictor (looks like a clear washer about the size of a half dollar). 3) Using a pair of needle nose pliars, CAREFULLY squeeze the tabs on the black retaining "C-clip" and remove from the filter housing. DO NOT BREAK THE RETAINING CLIP WHILE REMOVING. The retaining clip is very brittle, if you do break it, you'll have to purchase the whole flow valve unit since Hayward does not offer the retaining clip as a seperate part (voice of experience speaking). Once the retaining clip is out, all you have to do is pull out the check valve from the filter housing (pulling towrd you from the outside of the filter housing).
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'