Pump leaking

Reply

  #1  
Old 08-07-07, 12:04 AM
Member
Thread Starter
Join Date: Aug 2007
Location: USA
Posts: 37
Pump leaking

My Whisperflo 1.5hp pump is leaking - I just replaced all the seals including the shaft seal. Before changing the seals it was leaking pretty bad, now it isn't too bad - I can't tell exactly where the leak is coming which makes it harder to troubleshoot.

Anyone else had trouble with the Whisperflo?

Could it be the seal plate? It didn't look that bad when I had it apart but at the moment that is the only thing I can think of..............

Thanks in advance!!
AZSobo
 
Sponsored Links
  #2  
Old 08-07-07, 06:51 AM
todrut's Avatar
Member
Join Date: Jun 2007
Location: USA
Posts: 1,212
It could be the Seal plate, could have a hairline crack where the seal goes in, I've seen it many times. It could also be the seal itself, not seated properly? Touched when installing? Did you lube it? It should never be lubed.
 
  #3  
Old 08-07-07, 09:43 AM
Member
Thread Starter
Join Date: Aug 2007
Location: USA
Posts: 37
I'm a Little confused:
I wasn't supposed to lube the gasket that goes on the seal plate?

The booklet that came with the pump says to lube everything except the shaft seal, I do know from past experiences that those books can be wrong though!!

I inspected the seal plate pretty good but could have missed a hairline crack, is there any part of the plate that has a high failure rate?

Thanks,
AZSobo
 
  #4  
Old 08-07-07, 07:51 PM
todrut's Avatar
Member
Join Date: Jun 2007
Location: USA
Posts: 1,212
Other than the crack now and then, seal plates last forever unless pump runs dry(hot).

No, you should never lube any part of the seal, if its hard getting into the seal plate, a drop or two of spittle on only the rubber will do the trick.

Also make sure not to touch seal with hands as oil from hands will cause failure...
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'