Heater Turns Off

Reply

  #1  
Old 02-18-08, 11:23 PM
Member
Thread Starter
Join Date: Feb 2008
Posts: 1
Question Heater Turns Off

Hi all,
I have also a Hayward H100ID pool heater (natural gas). Its about 5 years old and it worked good last 2 yrs till last week. Here is what it does now, when turned on the fan starts then it ignits and the flame comes on. I can see the flame through the little peephole and feel the heat comming out the vent. The flame stays on for about 10 seconds then goes out but the blower fan stays on. The water flow pressure is good, there's gas and the pool filter is clean. Only works for minutes when the water its cold, then it stops and doesn't work anymore.

Anyone have any ideas?

Thanks for your help.
 
Sponsored Links
  #2  
Old 02-19-08, 07:30 AM
todrut's Avatar
Member
Join Date: Jun 2007
Location: USA
Posts: 1,212
Sounds like a venting problem. Clean heater, the heat exchanger especially. I think your heat exchanger is probably not letting the heat through it causing the safety to shut down heater.
 
  #3  
Old 02-20-08, 05:20 PM
Member
Join Date: Dec 2004
Location: So. Calif.
Posts: 540
i believe that model has a flame sensor, look on your schematics it should be with or by the ele pilot assy, when the heater fires if there is no flame reconition the iid ignition control will shut the heater off the fan will continue to run for a time to purge any remaning gas .

steve
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'