Weslo Icon Daybreak 515 Spa Error Codes?

Reply

  #1  
Old 05-13-08, 08:57 AM
Member
Thread Starter
Join Date: May 2008
Location: USA
Posts: 11
Weslo Icon Daybreak 515 Spa Error Codes?

I have a 10 year old Weslo Daybreak 515 spa that is displaying "FLO" and the heater light is blinking. I have tried all the owner's manual suggestions like: topping off water level, cleaning the filter, and even disconnecting the power to allow a reset. But the error code continues to be displayed. I don not see any water leaking from under the spa.

Any ideas??????

Mark
SAT
 
Sponsored Links
  #2  
Old 05-13-08, 09:49 AM
Member
Join Date: Apr 2002
Location: USA
Posts: 201
"FLO" indicates that the controls are not sensing enough water flowing through the heater to allow it to be activated. The most common reason is a clogged filter. Try taking out the filter cartridge, running the system, and see if it then works. If it does, and you've already cleaned the filter, it's indicated the cartridge is worn out and needs replacing. Other causes could be a clogged pump impeller, faulty or out-of-adjustment flow sensor or pressure switch.
 
  #3  
Old 05-13-08, 10:58 AM
Member
Thread Starter
Join Date: May 2008
Location: USA
Posts: 11
Weslo Icon Daybreak 515 Spa Error Codes?

OK............................Thanks for the tips. Water flow is good, there is strong pressure from all of the jets, so I should look at the flow sensor or pressure swithch. Are these adjustable or a relacement item?

Thanks,

Mark
SAT
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'