Go Back  DoItYourself.com Community Forums > Garden and Outdoor Center > Pools, Spas and Hot Tubs
Reload this Page >

PSOL - Error Message on Spa/Hot Tub/Jacuzzi

PSOL - Error Message on Spa/Hot Tub/Jacuzzi

Reply

  #1  
Old 05-04-09, 07:52 PM
Member
Thread Starter
Join Date: May 2009
Location: Washington, DC
Posts: 3
PSOL - Error Message on Spa/Hot Tub/Jacuzzi

I bought a Pheonix Spas "Mariah" hot tub about four years ago, which sits just off of my deck. This past fall it stopped pumping and it flashed "PSOL." I looked that up on the internet and it has something to do with the pressure being off on the low side pump (it has two pumps). It was getting cold quick so I drained the tub, and tried to get a service person out to look at it. It was too cold by the time I ever got a call back and he said I would have to wait until it got warmer . . . and he added he hoped that none of the water had frozen in the pipes and done any damage. I lost his number and every other service company says they don't service this brand (I still have some more to call but I gave up after 5 turned me down). This spring we filled it back up, cleaned the filters and tried to fire it up but same message "PSOL." Pheonix spas keeps saying they will call or email me back about what I can do, or who I can call in this area (Washington, DC) to service it, but they haven't yet. I'd like to do it myself if I can.
 
Sponsored Links
  #2  
Old 05-26-09, 12:04 PM
Member
Join Date: May 2009
Location: CA
Posts: 1
PSol - Pressure Switch Error Message

Dalin,

The pressure switch may need to be replaced.

PSoL = Pressure switch open with low pump

SpaBro,
 

Last edited by todrut; 05-26-09 at 02:24 PM. Reason: please don't post url's
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'