Go Back  DoItYourself.com Community Forums > Garden and Outdoor Center > Pools, Spas and Hot Tubs
Reload this Page >

Topside Control Says 102 But Actual Temperature Of Water Is 97

Topside Control Says 102 But Actual Temperature Of Water Is 97

Reply

  #1  
Old 09-30-12, 03:33 PM
katiefran's Avatar
Member
Thread Starter
Join Date: Mar 2003
Location: Chicago, Illinois
Posts: 143
Topside Control Says 102 But Actual Temperature Of Water Is 97

Hello, I have a Island Spa Grand Bahama 54 jet made by Artesian from 2003. A year ago I had to change out the main control panel with a new one made by Gecko. SInce then My water temperature is not as hot as the top panel says it is. Just to test it I set the temperature on top panel to 102 degrees and left it all night. Next day I tested the water with 3 differant thermometers and they all read betwee 97 and 96 degrees. I have read that I should test the temperature probe. How do I get to it. I dont want to force that little cover thing off it because I don't know if I am suppose to. ALso I read some thermostats need to be calibrated. How do I get to the thermostat? ANd how do I know if this is the type to calibrate. Before this new control panel was put it the termperature was perfect. The new control panel did come with a new temperature probe but we just kept the old one in because we didn't know how to change it and figured that it was good. Thanks, Katie
 
Sponsored Links
  #2  
Old 09-30-12, 04:42 PM
Group Moderator
Join Date: Mar 2003
Location: NC, USA
Posts: 17,648
If your spa is holding temperature it sounds like the controls and temp probe/senor are working. You need to calibrate it so the display matches the water temperature. To do that you'll have to find the instructions for your control panel or contact the manufacturer. If the controls cannot be calibrated to your old temp probe you may have to install the probe that came with your controller.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'