Go Back  DoItYourself.com Community Forums > Garden and Outdoor Center > Pools, Spas and Hot Tubs
Reload this Page >

Sundance Spa Control panel Sentry 800 problems

Sundance Spa Control panel Sentry 800 problems

Reply

  #1  
Old 07-07-14, 07:43 PM
Member
Thread Starter
Join Date: Jul 2014
Location: USA
Posts: 1
Sundance Spa Control panel Sentry 800 problems

I recently resurrected an early 90's Sundance spa. Believe it or not, I was able to get everything to work. It's been running for about 2 weeks now and when I went out today to check on it, I found that the control panel at the top of the spa was completely blank. I checked the power supply and I have power to the main control box below with the circuit boards and relays in it. I'm wondering where I should begin my troubleshooting. Any help would be much appreciated! I'm new to this site so will have to wait and see if there is anyone out there who can help.
 
Sponsored Links
  #2  
Old 07-07-14, 09:29 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 44,439
Welcome to the forums.

Most of those boards have a 3-4A fuse on them near where the power connects for the board.

Is this a 120v or 240v model ?
 
  #3  
Old 07-20-14, 08:04 AM
Member
Join Date: Jul 2014
Location: USA
Posts: 1
Similar sentry power failure

My 2003 sundance spa just started with a similar problem. It acts as of the breaker is tripping although it's not. I can turn the breaker on/off and the spa panel LCD lights up, flashes OH then - - - - then goes blank. I have checked the heater and it down not appear that there is any arcing. Nothing on the circuit board looks blown. Any ideas? It's a 240v on GFCI
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'