Jacuzzi Quantum not heating properly

Reply

  #1  
Old 08-15-15, 03:36 PM
Member
Thread Starter
Join Date: Aug 2015
Posts: 1
Jacuzzi Quantum not heating properly

I have a Jacuzzi Quantum Hot Tub, Model #: 7700000. The piping is all flowing properly, but there is a problem with the heater. When I turn the hot tub on, the jets come on, but the little light on the temperature select knob doesn't come on. The heater is not turning on when "HEAT" is selected. If I manually press the heater relay on the control panel, the heater turns on and heats the water up, but as soon as I let go of the relay, the heater turns back off again. I don't know how to check the voltages of different parts to see what is working and what isn't working. I am an automotive mechanic, so if I know what the readings are supposed to be, I can find the problem before throwing parts at it. Any help is greatly appreciated. Thank you very much.
 
Sponsored Links
  #2  
Old 08-16-15, 12:09 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 44,359
Welcome to the forums.

I need more info.
Year of manufacturer.
Is there a control box inside with model or type number on it ?
I'm thinking a defective temperature sensor or pressure switch.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'