Go Back  DoItYourself.com Community Forums > Garden and Outdoor Center > Pools, Spas and Hot Tubs
Reload this Page >

Hayward RS2000 Pump Rebuild-Still Leaking / 2hp Saltwater Hot Tub

Hayward RS2000 Pump Rebuild-Still Leaking / 2hp Saltwater Hot Tub

Reply

  #1  
Old 08-23-15, 06:31 PM
Member
Thread Starter
Join Date: Aug 2015
Posts: 3
Hayward RS2000 Pump Rebuild-Still Leaking / 2hp Saltwater Hot Tub

I replaced the water slinger, motor housing plate, motor seal plate, shaft seal (did not touch the seals), impeller, wear ring, diffuser and diffuser gasket. The ribbon gasket was perfect, yet my pump still leaks between the Pump and motor seal.

Is it possible that my pump housing is warped? If so, can someone suggest a fix?

Thanks in advance.
 
Sponsored Links
  #2  
Old 08-23-15, 09:23 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 44,444
Welcome to the forums.

You replaced the shaft seal but you did not touch the seals ??

Your leak may very well be the pump/motor shaft seal. Usually if the housing is leaking you'll see water coming out at the housing seal point.

Name:  Super2Pump_Breakdown.jpg
Views: 989
Size:  28.8 KB
 
  #3  
Old 08-24-15, 04:39 AM
Member
Thread Starter
Join Date: Aug 2015
Posts: 3
What I intended to say was that I didn't touch the ceramic facing on the seals. But yes, I did replace the motor shaft seal..
 
  #4  
Old 08-30-15, 05:17 PM
Member
Thread Starter
Join Date: Aug 2015
Posts: 3
Ok, I gave up and purchased a new complete pump and motor. I'll replace the unit and take the pump facing to a machine shop and see if the face is warped.

I'll let you know the outcome.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'