Go Back  DoItYourself.com Community Forums > Garden and Outdoor Center > Pools, Spas and Hot Tubs
Reload this Page >

Can't find part for Jacuzzi Laser 500 filter!

Can't find part for Jacuzzi Laser 500 filter!


  #1  
Old 06-25-17, 10:07 AM
T
Member
Thread Starter
Join Date: Nov 2001
Location: CANADA
Posts: 269
Upvotes: 0
Received 0 Upvotes on 0 Posts
Can't find part for Jacuzzi Laser 500 filter!

Help!

My pool was getting fine debris coming in from the return lines, and I was told the spider/diverter gasket likely need replacing.

I ordered one and took the filter apart and removed the old gasket, destroying it in the process. When I went to install the replacement, I realized the new one won't work at all - not the same thickness or configuration.

I'm supposed to be having a pool party next weekend, so I spent the past 45 minutes trying to find a proper replacement. There is no part # on the old one, and I have searched for the part in dozens of online parts diagrams - unsuccessfully.

All suggestions most appreciated.

Photos attached. White one is the original.
 
  #2  
Old 06-25-17, 12:58 PM
S
Banned. Rule And/Or Policy Violation
Join Date: Jun 2017
Location: USA
Posts: 700
Upvotes: 0
Received 0 Upvotes on 0 Posts
The pics didn't make it.
___________________
 
  #3  
Old 06-25-17, 01:29 PM
T
Member
Thread Starter
Join Date: Nov 2001
Location: CANADA
Posts: 269
Upvotes: 0
Received 0 Upvotes on 0 Posts
Hmmm

Here they are. I must have goofed first time.
 
Attached Images   
  #4  
Old 06-25-17, 01:36 PM
S
Banned. Rule And/Or Policy Violation
Join Date: Jun 2017
Location: USA
Posts: 700
Upvotes: 0
Received 0 Upvotes on 0 Posts
  #5  
Old 06-25-17, 02:18 PM
T
Member
Thread Starter
Join Date: Nov 2001
Location: CANADA
Posts: 269
Upvotes: 0
Received 0 Upvotes on 0 Posts
Thanks! I have one ordered.
 
  #6  
Old 06-25-17, 02:51 PM
Shadeladie's Avatar
Super Moderator
Join Date: Jan 2005
Location: PA - USA
Posts: 4,935
Received 405 Upvotes on 332 Posts
I must have goofed first time.
No you didn't goof. There's a problem with uploading pics. Amazing you were able to!
 
  #7  
Old 07-07-17, 01:05 PM
T
Member
Thread Starter
Join Date: Nov 2001
Location: CANADA
Posts: 269
Upvotes: 0
Received 0 Upvotes on 0 Posts
Still not the right gasket...

I looked at the new gasket, and it was the same configuration as the old one and looked close but not identical.

I gave it a try and it won't work. Although the overall thickness is the same, the part that goes into the spider valve is not as deep and the part that goes into the filter base is too thick/high.

When the multi-port is mounted on the filter, dial cannot move due to the friction of the gasket...

I'd hate to have to get a new filter because I can't find a $10. part.

Some photos attached that may help.
 
Attached Images    
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: