Pentair Quad 60 DE filter

Reply

  #1  
Old 09-08-17, 09:05 PM
B
Member
Thread Starter
Join Date: Sep 2017
Location: US
Posts: 18
Received 0 Votes on 0 Posts
Pentair Quad 60 DE filter

afterbcleaning and replacing de my filter runs fine for about 2 weeks then the psi goes up and the crawler stops moving. I generally run at 1800 speed. Any idea?
 
Sponsored Links
  #2  
Old 09-08-17, 09:32 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 59,166
Received 1,114 Votes on 1,034 Posts
Usually when the pressure rises it means it's time for the filter to be backwashed.
 
  #3  
Old 09-09-17, 04:11 PM
B
Member
Thread Starter
Join Date: Sep 2017
Location: US
Posts: 18
Received 0 Votes on 0 Posts
Thanks for the reply. I'm having issue with backwashing this. I don't see a backwash option in my control panel. I opened the bottom of the filter and let the water out and ran the pump for a minute but it didn't fix the pressure. Any suggestion?
 
  #4  
Old 09-09-17, 04:51 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 59,166
Received 1,114 Votes on 1,034 Posts
The quad 60 DE is just the filter part of the system. You need a 5-6 way valve to direct water thru the filter and system. It's this valve that has backwash on it. It directs the water thru the filter in the opposite direction.
 
Attached Images  
  #5  
Old 09-10-17, 06:19 AM
B
Member
Thread Starter
Join Date: Sep 2017
Location: US
Posts: 18
Received 0 Votes on 0 Posts
I'm recently moved into this house, so not much experience yet with this filter. Here is a pic of my system if you have any pointers. No idea why image isn't loading...

https:/
/ibb.
co/jwOWBv
 
  #6  
Old 09-10-17, 09:29 AM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 59,166
Received 1,114 Votes on 1,034 Posts
ibb. co is currently blocked from the DIY site due to ransomeware found in pictures they were hosting. Attach the picture directly to the board. Use the attach instructions in the red box.

http://www.doityourself.com/forum/el...-pictures.html
 
  #7  
Old 09-10-17, 02:46 PM
B
Member
Thread Starter
Join Date: Sep 2017
Location: US
Posts: 18
Received 0 Votes on 0 Posts
Awesome thanks. Here it is
 
Attached Images  
  #8  
Old 09-10-17, 04:42 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 59,166
Received 1,114 Votes on 1,034 Posts
Simple and Easy Cleaning

Cleaning the Quad D.E. filter couldn’t be easier. You have three options: backwash and recharge like a traditional D.E. filter, remove and rinse off the cartridges, or simply remove the lid, leave the cartridges in place, open the drain plug and rinse.
Since you don't have a backwash valve installed you will need to clean the filter manually.

This is a link to your filter manual...
pentair pool/downloads/filters/quad de owners manual english.pdf
 
  #9  
Old 09-10-17, 06:28 PM
B
Member
Thread Starter
Join Date: Sep 2017
Location: US
Posts: 18
Received 0 Votes on 0 Posts
Damn that's what I thought. It's kind of crappy because it requires so much de and takes a while to manually clean. Well thanks for the help. It seems 2 weeks is usually when it needs to be changed. Is that consistent in your experience?
 
  #10  
Old 09-10-17, 07:28 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 59,166
Received 1,114 Votes on 1,034 Posts
Based on what's in the water and the amount of "stuff" that falls in.... that would be about right.
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: