Dream Maker Hot Tub

Reply

  #1  
Old 10-30-20, 11:10 AM
W
Member
Thread Starter
Join Date: Oct 2020
Posts: 4
Received 0 Votes on 0 Posts
Dream Maker Hot Tub

I have a Dream Maker Hot Tub, model X4H-UHS-DMI-GG-F, 120 volt. It heats up perfectly, lights and temperature work perfectly. But when I'm sitting in the hot tub and I press on the jets button, the jets won't turn on. The jets turn on by themselves of course to heat the hot tub, but if I want to turn them on manually using the button it just doesn't work. I opened the metal box where the control board is and checked all of the connections and they are super clean/perfect and tight. I do seem to have to press kinda hard to turn the temp up and down. Do you think I just need a new display or what do you suggest I try first to get the jets working? Thank you for any help!
 
  #2  
Old 10-30-20, 11:30 AM
P
Group Moderator
Join Date: Mar 2003
Location: NC, USA
Posts: 24,457
Received 752 Votes on 691 Posts
It does sound like a control issue. My first guess would be the top side control panel but before ordering a replacement I would disconnect it's cable and reconnect a few times to see if that gets it working. Hopefully it's just a corroded connection.
 
  #3  
Old 10-30-20, 11:56 AM
W
Member
Thread Starter
Join Date: Oct 2020
Posts: 4
Received 0 Votes on 0 Posts
Ok yeah I'll take the box top off again and check it again, thank you. The computer board and stuff were very clean like maybe they had been replaced already, they look brand new.
 
  #4  
Old 11-07-20, 01:43 PM
W
Member
Thread Starter
Join Date: Oct 2020
Posts: 4
Received 0 Votes on 0 Posts
new control panel didn't do it

Well I checked all of the connections, and I bought a new display/control panel and it didn't fix it. I hate to replace the entire board and find out it's some pump problem or something.
 
  #5  
Old 11-07-20, 01:47 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 60,896
Received 1,343 Votes on 1,241 Posts
The jets turn on by themselves of course to heat the hot tub, but if I want to turn them on manually using the button it just doesn't work
If they turn on by themselves.....it can't be a pump problem.

What is the part number off the control board ?
 
  #6  
Old 11-09-20, 05:39 AM
W
Member
Thread Starter
Join Date: Oct 2020
Posts: 4
Received 0 Votes on 0 Posts
Balboa RS80 Part # 22962 Rev. A and then the display panel is Balboa MVP240. The new display panel which I bought has the same controls which I don't think is the issue is VL200 Balboa, I bought it from wildwestpoolsupplies Balboa mini oval heat jacket 4 button 53238.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: