Search: Posts Made By: THX723
Showing results 1 to 5 of 5
Search took 0.01 seconds.
01-14-21, 03:52 PM
Replies: 10
Views: 306
Posted By THX723

I replaced it with yet another Ecobee (previous...

I replaced it with yet another Ecobee (previous one has been working flawlessly for the past 5 years). Whatever it was that went bad inside, it sure caused me a few gray hairs and several cold...
01-14-21, 02:39 PM
Replies: 10
Views: 306
Posted By THX723

@Pjmax I stand corrected. This is in fact flame...

@Pjmax I stand corrected. This is in fact flame sense rod not thermocouple. I have them backwards. And yes, intermittent pilot is the setup here.

Now for the update...

Son of a gun, it was the...
01-13-21, 10:28 PM
Replies: 10
Views: 306
Posted By THX723

This is an older furnace that uses thermocouples;...

This is an older furnace that uses thermocouples; no flame sense rods. You are however correct on transformer, not power supply. Brain fade. :)

The output of the transformer checked out at 28V as...
01-12-21, 11:11 PM
Replies: 10
Views: 306
Posted By THX723

Thanks for chiming in guys. Turns out that...

Thanks for chiming in guys.

Turns out that jumper plug simply pulls right out. The extra leg had me fooled thinking it was hard soldered onto the PCB.

Unfortunately my problem persisted even...
01-11-21, 10:09 PM
Replies: 10
Views: 306
Posted By THX723

Question Furnace Ignition Module Terminal Question

Howdy!

I'm a little stumped after diagnosing my furnace issue (not firing off the main valve) to a faulty ignition module from Robertshaw; pilot lights up okay and stays lit btw. I thought it'd be...
Showing results 1 to 5 of 5


 
Forum Jump