Search: Posts Made By: Veto001
Showing results 1 to 7 of 7
Search took 0.01 seconds.
02-19-08, 03:26 PM
Replies: 9
Views: 12,765
Posted By Veto001

flame problem!!

I replaced the flame sensor today and I made sure it was engulfed in the flame and it keeps doing the same thing. I even replaced the harness and thermostat. The thing fires up and right after...
02-18-08, 05:34 AM
Replies: 1
Views: 1,038
Posted By Veto001

Need Answers?

Need Answers?

--------------------------------------------------------------------------------

I have a job that unfortunately thieves target almost nightly, "Job Security". Anyway, someone...
02-17-08, 08:51 PM
Replies: 9
Views: 12,765
Posted By Veto001

RE:Gas Problem

I attempted to clean it the other day and I even replaced the limit switches just above the flame tubes. Could there be some sort of restriction in vent pipe that might make this happen?
02-17-08, 10:17 AM
Replies: 20
Views: 5,036
Posted By Veto001

Rudd Gas Furnace Problem!

Rudd Gas Furnace Problem!

--------------------------------------------------------------------------------

Rudd Gas Furnace Problem!
...
02-17-08, 09:40 AM
Replies: 4
Views: 1,596
Posted By Veto001

Rudd Gas Furnace Problem!

Rudd Gas Furnace Problem!

--------------------------------------------------------------------------------

Rudd Gas Furnace Problem!
...
Replies: 1
Views: 959
Posted By Veto001

Rudd Gas Furnace Problem!

Rudd Gas Furnace Problem!

--------------------------------------------------------------------------------

Can any one out here help me with this dilema that I'm having? I have a 2004 Rudd...
02-17-08, 06:43 AM
Replies: 9
Views: 12,765
Posted By Veto001

Rudd Gas Furnace Problem!

Can any one out here help me with this dilema that I'm having? I have a 2004 Rudd Achiever Series "Super Quiet 80" gas furnace and the problem I'm having is after I set the thermostat in heat mode...
Showing results 1 to 7 of 7


 
Forum Jump