Search: Posts Made By: Ozzmosis86
Showing results 1 to 5 of 5
Search took 0.01 seconds.
Replies: 11
Views: 38,326
Posted By Ozzmosis86

I fixed the problem..... It was a damned rock!!! ...

I fixed the problem..... It was a damned rock!!! It got stuck between the impeller and the pump housing. Don't ask me how it go there, but it is working fine now.

Thanks for the help and the...
Replies: 11
Views: 38,326
Posted By Ozzmosis86

Haha, thanks for the advice. I talked with the...

Haha, thanks for the advice. I talked with the guy that installed the plumbing in my house when it was built. I am going to try to pull the pump up and see if I can get it to run with it pulled...
Replies: 11
Views: 38,326
Posted By Ozzmosis86

Is there anything holding the pump in place other...

Is there anything holding the pump in place other than the drain pipe? Can I just life the pump by breaking the joint where the back flow valve is located and try to run it?

The sump is...
Replies: 11
Views: 38,326
Posted By Ozzmosis86

I had a thought this morning. Is it possible...

I had a thought this morning. Is it possible that the pump lost it's prime? I had run the pump manually recently, since that seemed to help with the gurgling if I did that periodically. Could I...
Replies: 11
Views: 38,326
Posted By Ozzmosis86

Sewage Ejector Pump Problems

I am having problems with my sewage ejector pump in my basement. I should start the story off with a mistake I made. I was doing some framing in my basement and threw a breaker on the same circuit...
Showing results 1 to 5 of 5


 
Forum Jump