Search: Posts Made By: mr_franksmith
Showing results 1 to 25 of 40
Search took 0.02 seconds.
Replies: 5
Views: 4,933
Posted By mr_franksmith

Greetings

Check inside the fuse block.
Replies: 3
Views: 624
Posted By mr_franksmith

Greetings

Id start at the main relay.
Replies: 30
Views: 66,612
Posted By mr_franksmith

Greetings

Tobacco works well, My Grandpa used it all the time.
Replies: 1
Views: 869
Posted By mr_franksmith

Greetings

P0446, Evaporative Emission Control System Vent Control Circuit Malfunction
Replies: 2
Views: 1,076
Posted By mr_franksmith

Greetings

Could be the Brake wear sensors, If so replace the Pads.
Replies: 3
Views: 1,091
Posted By mr_franksmith

Greetings

General Motors products had this problem a few years back.
Check the evaporator drain tube for a blockage.
GM makes an aerosol, sanitizing spray that you spray into the evaporator case to cure the...
Replies: 3
Views: 768
Posted By mr_franksmith

Greetings

There not to difficult to change. That grinding noise may be a bad ring gear on the flex plate.
Replies: 2
Views: 962
Posted By mr_franksmith

Greetings

I believe you need a press. Most Fords have the bearings pressed onto the axle shaft.
Replies: 1
Views: 1,330
Posted By mr_franksmith

Greetings

Up and down movement tells me you have a loose wheel bearing or a bad ball joint. Side to side could be wheel bearing, Tie rods, Idler or pitman arms.
Replies: 5
Views: 13,077
Posted By mr_franksmith

Greetings

First thing to look at is the oil pressure sending unit.
Its located behind the intake manifold next to the distributor.
They leak all the time.
Replies: 2
Views: 739
Posted By mr_franksmith

Greetings

To service the Trans you need to remove the oil pan, replace the filter and refill.
Replies: 2
Views: 746
Posted By mr_franksmith

Greetings

Has anyone checked the fluid?
Is it low? Does it smell burnt? Is it bright red?
Replies: 2
Views: 1,835
Posted By mr_franksmith

Greetings

You might have lost or damaged the O-rings.
Did you replace the fittings?
Replies: 2
Views: 753
Posted By mr_franksmith

Greetings

I concur with wrench47. However, I dont think your cylinder head gaskets are blown yet.
Good luck
Replies: 1
Views: 1,108
Posted By mr_franksmith

Greetings

In most Hondas they are located where the dash and left kick pannel meet.
THE MAIN RELAY IS LOCATED BY YOUR FUSE BOX UNDER YOUR STEERING WHEEL ON THE LEFT SIDE.. LOCATE YOUR FUSE BOX AREA, THE ON...
Replies: 7
Views: 17,813
Posted By mr_franksmith

Greetings

The Tow guy is right, You need a GM Tech 2 scanner to unlock
Go to the dealer.
Replies: 2
Views: 1,005
Posted By mr_franksmith

Greetings

There was a large recall on circuit boards for a lot of RV fefers.
Replies: 14
Views: 1,129
Posted By mr_franksmith

Greetings again

Yeah, You gotta have a bad guage. There should be 8 to 15 Psi there.
Replies: 14
Views: 1,129
Posted By mr_franksmith

Greetings again

Is that 0 PSI, Engine off or Running?
Replies: 4
Views: 890
Posted By mr_franksmith

Greetings again

The round black canister between the master cylinder and the firewall is the booster. Pull the hose off while the car is running
to see if you have vacum. If you do, the booster is bad.
Replies: 4
Views: 890
Posted By mr_franksmith

Greetings

Sounds too me like a bad Vacum brake booster.
Replies: 3
Views: 5,630
Posted By mr_franksmith

Greetings

Could be dirty or loose battery terminals, Bad cell in the battery, Corrosion internally in the cables or a starter going bad.
You need to run starting systems tests.
Replies: 3
Views: 1,170
Posted By mr_franksmith

SHURflo On-Demand Diaphragm Pump — 1 GPM, 60 PSI,...

SHURflo On-Demand Diaphragm Pump — 1 GPM, 60 PSI, 12 Volt, Model# 8000-541-236 | Sprayer Pumps | Northern Tool + Equipment...
Replies: 14
Views: 1,129
Posted By mr_franksmith

Greetings again

Too much starting fluid is not good on glow plugs.
There's a fuel pressure tap on the filter housing,
Looks just like a tire air valve. Install a guage to check pressure. Lift pump could be going...
Showing results 1 to 25 of 40
 


 
Forum Jump