Polyurethane Issue w/ hardwood floors

Reply

  #1  
Old 10-09-13, 03:26 PM
Member
Thread Starter
Join Date: Oct 2013
Posts: 1
Polyurethane Issue w/ hardwood floors

Greetings! First thank you for the taking the time to check out this post.

Here's my issue: My father-in-law decided that he wanted to paint our hardfloors with a high gloss, high build polyurethane coating (I believe the product used was minwax). After completing the job, the polyurethane coating developed what can best be described as a shattered-glass look, or almost like a spider-web effect. It appears that the polyurethane is cracked.

Has anyone here ever heard of this and if so, thoughts on how it might be able to be fixed? The wife'ss upset, the FIL's upset, and I'm stuck in the middle trying to save the day. Any help would be immensely appreciated! Thanks again for your time!
 
Sponsored Links
  #2  
Old 10-09-13, 03:55 PM
Banned. Rule And/Or Policy Violation
Join Date: Apr 2013
Location: USA
Posts: 4,297
Contacted Min Wax yet?
What prep work did he do?
Really humid while doing it? What's under that floor? Subflooring?
Is there a crawl space? If so is there a vapor barrier on the ground?
Anyone do a moisture test before sealing?
 
  #3  
Old 10-10-13, 03:21 AM
Forum Topic Moderator
Join Date: Mar 2005
Location: USA
Posts: 43,782
Welcome to the forums!

It sounds like the poly may have been applied too thick. If that's the case, sanding and recoating is the fix. Another possibility is it was applied over wax in that case it will need to be stripped off and redone. What prep work was done?

Will it show up in pics? http://www.doityourself.com/forum/el...-pictures.html
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes