Minwax High Build Polyurethane


  #1  
Old 08-10-14, 07:32 AM
D
Member
Thread Starter
Join Date: Aug 2014
Posts: 1
Upvotes: 0
Received 0 Upvotes on 0 Posts
Minwax High Build Polyurethane

Hi folks! I just did my first coat of Minwax High Build Polyurethane on my hardwood floor in my dining room. While I gotta say I'm very happy with the high gloss, I am shocked at how many air bubbles appeared in this application. Previously I've used Varithane on other projects and I didn't encounter this. Has anyone else encountered this in this product? I'm worried that it was my application (lambs wool) and I'm honestly dreading the sanding that will come prior to my second coat (which the can says is 8-12 hours, but it IS humid this morning, so...).

Thoughts? I'll keep everyone posted on the progress.
 
  #2  
Old 08-10-14, 09:42 AM
M
Forum Topic Moderator
Join Date: Mar 2005
Location: USA - N.E.Tn
Posts: 45,737
Received 861 Upvotes on 753 Posts
Welcome to the forums!

Did you use a pad or roller to apply the poly? The biggest cause for bubbles in poly is shaking the can instead of stirring it.
 
  #3  
Old 08-10-14, 12:53 PM
N
Member
Join Date: Aug 2006
Location: santa fe /texas
Posts: 947
Upvotes: 0
Received 0 Upvotes on 0 Posts
As Marksr stated,
the first time I used it I got all these bubbles- because I Shook the can.
Since i quit doing that I have had Excelent results
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: