Changing from a Robertshaw 9420 to a Honeywell RTH7500

Reply

  #1  
Old 01-31-09, 11:18 PM
S
Member
Thread Starter
Join Date: Jan 2009
Posts: 2
Received 0 Votes on 0 Posts
Question Changing from a Robertshaw 9420 to a Honeywell RTH7500

Running a heat pump. The new Honeywell combines O and B and says to put B on C. Well, I was not here when the old t-stat came down, so I don't know which is which.

I have a red, yellow, green, blue, brownish, white wires. I've been researching for darn near 12 hours today. Any tips appreciated!
 
  #2  
Old 02-01-09, 10:45 AM
S
Member
Join Date: Sep 2008
Location: Long Island
Posts: 768
Received 0 Votes on 0 Posts
check down on the air handle to see if they land on lettered terminals R/RED....HOT 24Vs to Rc-Rh on subbase....G/FAN........GREEN to eliminate a couple
 
  #3  
Old 02-02-09, 08:25 AM
Jay11J's Avatar
Member
Join Date: Sep 2001
Location: Rochester, Minnesota
Posts: 18,427
Received 0 Votes on 0 Posts
If you were not there, or no one made notes of what letters when to what color, then as Sminker said, you'll have to go to the air handler/furnace, and see what colors letter went to where.
 
  #4  
Old 02-02-09, 10:13 AM
S
Member
Thread Starter
Join Date: Jan 2009
Posts: 2
Received 0 Votes on 0 Posts
Question Old Connections

The old connections were:

OldT-stat Color
C========Blue
R========Red
Y1======Yellow
E========Brown
W2=======White
G========Green
O========Orange
B========(nothing)
L========(nothing)

New options are:

C
G
Y
O/B
RC
R
AUX
E
L

I appreciate everyones time...
 
  #5  
Old 02-02-09, 10:17 AM
Jay11J's Avatar
Member
Join Date: Sep 2001
Location: Rochester, Minnesota
Posts: 18,427
Received 0 Votes on 0 Posts
OldT-stat--Color----New
C=====Blue-------C
R=====Red--------R/Rc
Y1====Yellow------Y
E=====Brown------E
W2====White------Aux
G=====Green------G
O====Orange------O/B
 
  #6  
Old 07-20-10, 07:35 PM
V
Member
Join Date: Jul 2010
Location: usa
Posts: 1
Received 0 Votes on 0 Posts
Changing From RobertShaw 9620 to Honeywell RTH7500

I am lost with this whole thing!
I called Honeywell and the tech told me to connect like this:

Honeywell RTH7500
New-stat
C===BROWN
R===RED (Leave jumped between R and RC)
Y===YELLOW
G===BLUE
W2==WHITE (jump between W2/Aux and Y2/E)
O===GREEN

I did this and then turned on AC and it was blowing hot air.
Here is what the wires are connected to on the

RobertShaw 9620
Old-stat--Color
C=====Brown
L=====Blank
R=====Red

Y2====Blank
Y1====Yellow
E=====Blank
G=====Blue
W2====White
O=====Green
B=====Blank

Any help would be very much appreciated.
 
  #7  
Old 07-20-10, 09:57 PM
Jay11J's Avatar
Member
Join Date: Sep 2001
Location: Rochester, Minnesota
Posts: 18,427
Received 0 Votes on 0 Posts
You got it wired up right..

T-stat set up menu.

170-7
180- I don't know what is your back up heat?)
190-0
240-3
270-3
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: