Problem with Trane Air Handler


  #1  
Old 03-04-14, 07:24 AM
A
Member
Thread Starter
Join Date: Mar 2014
Location: USA
Posts: 1
Received 0 Votes on 0 Posts
Problem with Trane Air Handler

Good morning, I have a Trane Air Handler model # TWE048P13FBO coupled with a Honeywell thermostat model #RTH7600D and I've had several issues over the last several weeks. First, I was having issues with my thermostat and talked to Honeywell and they walked me through reprogramming my thermostat and that fixed the issue. Then I had the same problem a week later and Honeywell said it appears a low voltage fuse had blown (which it had and replaced and it worked again). Now I have the problem again and once again I spoke to Honeywell and they had me to touch the red & white wires (wires going to thermostat) and nothing happened in which Honeywell said it was an air handler issue. Any light than you can shed on my issue is greatly appreciated. (one last note: when Honeywell reprogrammed my thermostat I didn't go back & forth from Heat to AC, so I don't know after I reprogrammed if I had went to ac from heat if my ac would have worked) Thanks for your time. Alan
 
  #2  
Old 03-04-14, 07:52 AM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 62,170
Received 1,528 Votes on 1,411 Posts
Welcome to the forums.

You didn't say what the actual problem was so I'm guessing the fuse blew again.
Does your current thermostat have a wire connected to the C terminal ?
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: