Fluidmaster fill valve problem

Reply

  #1  
Old 12-15-04, 02:07 PM
C
Member
Thread Starter
Join Date: Sep 2002
Location: Mesa,Az
Posts: 100
Received 0 Votes on 0 Posts
Fluidmaster fill valve problem

Toilet working great till to day ,it was flushed but it didn't fill back up.Took the valve apart and cleaned it run water into tank with valve out,worked ok.Put valve back in and the tank filled,flushed it and it didn't fill again.I did this several times and it always did the same thing again.Whats up?Cecil.
 
  #2  
Old 12-15-04, 03:24 PM
Rainbird's Avatar
Member
Join Date: Aug 2003
Location: California
Posts: 373
Received 0 Votes on 0 Posts
Follow the troubleshooting advice for Fluidmaster here:

http://www.toiletology.com/troubles.shtml
 
  #3  
Old 12-15-04, 08:19 PM
Plumber2000's Avatar
Member
Join Date: May 2000
Location: Eugene, Oregon
Posts: 5,838
Received 0 Votes on 0 Posts
Just install a new fkuidmaster.



Photo By Doityourself.com
 
  #4  
Old 12-18-04, 07:11 AM
5
Member
Join Date: Nov 2004
Location: CA
Posts: 2,039
Received 0 Votes on 0 Posts
Most of the time you can fix these just by removing the top cap. With the cap off,hold a rag over the top and turn on the water a little. You should get good flow of here, and also flush out any possible debris. Now just install a new seal washer in the cap and put it back on.
 
  #5  
Old 05-29-13, 10:01 AM
C
Member
Join Date: May 2013
Location: usa
Posts: 1
Received 0 Votes on 0 Posts
fill valve wont shut off

how to correct that issue?
 
  #6  
Old 05-29-13, 10:16 AM
lawrosa's Avatar
Super Moderator
Join Date: Dec 2010
Location: Galivants Ferry SC USA
Posts: 18,152
Received 62 Votes on 54 Posts
Probably sediment, but as you been advised...Just replace. They are cheap enough....
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: