perplexed - no cold water in shower


  #1  
Old 04-06-08, 10:25 AM
M
Member
Thread Starter
Join Date: Apr 2008
Posts: 3
Received 0 Votes on 0 Posts
perplexed - no cold water in shower

I have a danze sheridan single control mixer and im only getting hot water from it. I took the cartridge out to see if it was the problem but this doesnt appear to be the case: when i crack open the screw on the hot side inlet, hot water comes out. When I do the same on the cold side, nothing happens. In between the cold side screw and the outlet to the cartridge, there is a brass cover, but I havent tried opening it up yet. Could there be some sort of blockage in this part of the mixer?
 

Last edited by michaelma; 04-06-08 at 11:02 AM.
  #2  
Old 04-06-08, 12:11 PM
chandler's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Dec 2005
Location: USA
Posts: 39,964
Received 6 Votes on 6 Posts
Welcome to the forums! Is this a new installation? If so, I would look at the brass cover to be the problem. You may be able to post a pix of the unit and we can see what is going on. Post to a site such as photobucket.com and give us the urls.
 
  #3  
Old 04-21-08, 11:36 AM
M
Member
Thread Starter
Join Date: Apr 2008
Posts: 3
Received 0 Votes on 0 Posts
The problem turned out to be the pressure balancer that was located behind the brass cover. The sliding cylinder was seized, blocking cold water from coming out. After getting a new one from Danze, life is good again


Originally Posted by chandler View Post
Welcome to the forums! Is this a new installation? If so, I would look at the brass cover to be the problem. You may be able to post a pix of the unit and we can see what is going on. Post to a site such as photobucket.com and give us the urls.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: