Toilet tank filling extremely slowly

Reply

  #1  
Old 07-30-11, 08:39 AM
D
Member
Thread Starter
Join Date: Dec 2009
Location: Pennsylvania, USA
Posts: 173
Received 0 Votes on 0 Posts
Toilet tank filling extremely slowly

So a little over a year ago I posted this exact same problem of my toilet tank taking forever to refill and was told to replace my toilet fill valve which worked great. Today I wake up and find my toilet tank filling extremely slowly with a valve that has a 5 year warranty. It's a Hydroclean HC 660 I believe (can't actually see the model number). I have contacted the manufacturer, but, since I'd like to have a toilet that takes under an hour to fill sooner rather than later, can anyone see something from this video that I could do as a quick fix to the problem?

http://s737.photobucket.com/albums/xx13/DIYnewbie9/?action=view&current=ToiletValve.mp4
 
  #2  
Old 07-30-11, 09:15 AM
GregH's Avatar
Super Moderator
Join Date: Jan 2001
Location: Manitoba
Posts: 10,180
Received 47 Votes on 45 Posts
It is possible that some dirt has entered the valve and is blocking it.
You could remove the supply connector from the bottom of the valve then place the end in a bucket to see if you have sufficient flow.

You can try dismantling the valve and if unable to replacement would be required.
 
  #3  
Old 07-30-11, 09:18 AM
E
Member
Join Date: Mar 2009
Location: Texas
Posts: 1,051
Received 0 Votes on 0 Posts
Have you confirmed that you are getting a good supply flow through the shutoff valve? I am guessing your water is depositing minerals like calcium or lime either in the supply valve, the fill valve or both. You can quickly try opening and closing the supply valve a few times, or turning off the water and opening it up to check for deposits before you consider yet another fill valve replacement. I have similar problems with my toilets but in my case it is about noise that happens every 2 years or so, and rather than go with the expensive fill valves, I always just buy and install the $8 replacement ones that require a float and it never takes more than about 5 minutes to do that per toilet. I find it easier and faster than anything else.
 
  #4  
Old 07-31-11, 01:56 PM
D
Member
Thread Starter
Join Date: Dec 2009
Location: Pennsylvania, USA
Posts: 173
Received 0 Votes on 0 Posts
I did disconnect the fill valve from the supply and there doesn't appear to be any supply-side issues.

Before, I disconnected it I did try to turn the supply on and off again. Interestingly, it works, but only once. If I flush the toilet and it's going very slow if I turn off the supply then turn it back on again it works great. But when I flush it again, it's the exact same slowness. Turning the supply on and off again makes it work perfectly again.

Once I disconnected it, I tried to clean out the fill valve a bit with water and compressed air, but it didn't solve anything. Even after disconnect and reconnect it is doing the same thing with regards to turning the supply valve on/off.

Would this point to more of a fill valve issue or a supply issue?
 

Last edited by DIYnewbie9; 07-31-11 at 02:35 PM.
  #5  
Old 07-31-11, 04:59 PM
E
Member
Join Date: Mar 2009
Location: Texas
Posts: 1,051
Received 0 Votes on 0 Posts
My next step would be to unscrew the supply valve and see if there is any buildup inside between the seat, stem, and washer for example. I would completely eliminate supply as your issue because based on what you have said it would still be on my list to confirm. If there is mineral buildup inside your fill valve, taking it apart and using air will not resolve things. It would probably need to soak in a very strong vinegar solution, or a CLR type product overnight ensuring that the cleaning solution was completely inside the valve.
 
  #6  
Old 07-31-11, 06:27 PM
P
Group Moderator
Join Date: Mar 2003
Location: NC, USA
Posts: 24,737
Received 787 Votes on 724 Posts
I would turn off the supply to the toilet. Flush it to drop the water level in the tank (just in case). Pry the decorative cap off the top of the fill valve. Then you should be able to remove the valve core. Some have tabs to pry out and lift straight up while others have tabs you lift and then rotate the core to unlatch. With the core removed you can clean out anything clogging it but you may find that the diaphragm is brittle or cracked. In either case you don't have anything to loose and in many cases a cleaning is all it takes.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: