probably thermostat?


  #1  
Old 01-22-06, 08:57 AM
R
Member
Thread Starter
Join Date: Jan 2006
Posts: 6
Received 0 Votes on 0 Posts
probably thermostat?

My branford white 53 gal electric water heater has been tripping the red reset button for a few months...then it tends to get toooo hot....but sometimes doesn't trip for a week or so...Anyway, from reading here it appears a thermostat problem is likely. As you know, this has 2 thermostats, one on top under the red reste button. Is there anyway to know which thermostat is the problem (which is for existing and which is for new water or is that not the case with this heater), or might i best just go and relace both...Now showing my ignorance, is the top thermostat connected to the reset or are they seperate units....And last, th model says WH10A on top and WH9 on bottom, do I need more details to order or just bring old ones to store...Thanks..
 
  #2  
Old 01-23-06, 09:57 AM
N
Member
Join Date: Sep 2001
Location: Middle TN
Posts: 222
Received 0 Votes on 0 Posts
It sounds like you have one thermostat that is sticking in the "on" position. Replacements can be found at home depot or similar stores. I seem to recall that they run about $6 for the small one and a little more for the larger one. While you have it apart, I would change both.

Also, the top thermostat and reset are made into one unit and will come out as one piece.

Nashcat
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: