Beckett Hot water burner Not working


  #1  
Old 02-20-09, 04:20 PM
H
Member
Thread Starter
Join Date: Feb 2009
Location: canada
Posts: 4
Upvotes: 0
Received 0 Upvotes on 0 Posts
Question Beckett Hot water burner Not working

Hi, Today my hot water burner would not ignite., I am only getting the flashing green light on the reset. So, I pressed the reset once, nothing happened, I tried once more, nothing again. This time I had to hold the reset for 45 seconds to take it out of lockout, but when I did this, the light only flashed once, not twice as it should for the r7184b primary, then it went out, eventually it came back on and flashed every half second. I listened to primary and pressed the reset once, the light went out, and nothing happened, also heard buzzing within the primary.

I have lots of oil, clean nozzles etc...
I examined the electrode and they seem to look like the center of them are deteriated ( broken down ), would that cause the primary to not fire or attempt to fire? Also the pump does not come on during this.

I want to try what I can for now as the service man is gonna be here monday afternoon if I cannot get it running.

Thanks for any info



hammer
 
  #2  
Old 02-21-09, 11:54 AM
H
Member
Thread Starter
Join Date: Feb 2009
Location: canada
Posts: 4
Upvotes: 0
Received 0 Upvotes on 0 Posts
Fixed!

Fixed the problem, it was needing time to reset properly. I shut the power to it off at the breaker, let it sit overnight and today, I turned the power back on an voila, we have fire.

hammer
 
  #3  
Old 02-21-09, 05:41 PM
F
Member
Join Date: Mar 2006
Location: Wet side of Washington state.
Posts: 16,321
Received 39 Upvotes on 31 Posts
Glad you figured it out and thanks for posting how you did it. Although I am familiar with oil burners I have never seen an oil-fired water heater. I didn't have anything to offer.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: