Rheem water heater. Pilot goes off after heating water


  #1  
Old 10-31-12, 05:19 PM
T
Member
Thread Starter
Join Date: Oct 2012
Location: USA
Posts: 1
Upvotes: 0
Received 0 Upvotes on 0 Posts
Rheem water heater. Pilot goes off after heating water

Hi everyone,

For last week or so, I am facing following problem with my water heater. Its model number is Rheem Guardian 22V50F1. It is 6 years old.

The pilot goes off, after heating the water tank. It lights quickly via piezo ignitor. The flame is blue, both of the pilot and main burner. The air intake on the sides look clean. I don't think it is a thermocouple problem. I am not sure whether it is a gas valve issue.

There is some debris on the burner as I can see from the sealed glass door. I have read of similar problems with AO Smith heaters, and the way they could be resolved by vacuuming the bottom vent. But there is no vent on the bottom as visible from outside. The space there is really tight (like 1/2 cm).

I found some amount of water (very little) at the bottom of the heater.

I would appreciate any ideas on how to solve this problem.
 
  #2  
Old 11-11-12, 07:24 AM
lawrosa's Avatar
Super Moderator
Join Date: Dec 2010
Location: Galivants Ferry SC USA
Posts: 15,993
Received 85 Upvotes on 77 Posts
Your best bet at the moment would be to call rheem to see if you are still covered under warranty.

Usually 6 year on parts, although you would pay labor.

Contact info/warranty check

Rheem Product Warranty Information
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: