American Water Heater PowerFlex. No Hot Water


  #1  
Old 08-17-13, 06:40 PM
E
Member
Thread Starter
Join Date: Aug 2013
Location: USA
Posts: 1
Upvotes: 0
Received 0 Upvotes on 0 Posts
American Water Heater PowerFlex. No Hot Water

I have a 40gal NG American Water Heater (PowerFlex) model PVG6240T42NV. It has been installed for a little over a year now in our basement and we came home to no hot water today. I've googled for the past 2 hours and have turned to you in hopes for advice. The water heater is displaying the #6- Ignition/Flame error code. The powervent blower kicks on and the unit starts to cycle which fires up the igniter nice and bright and then it kicks off before it gets gas and attempts two more times before the FVIR goes into lockout. I've tried to reset the Intlli-Vent..White/Rogers control and no luck according to the moderators posting (Good Info BTW). Nothing is obstructing the exhaust vent and I'm assuming that the combustion air is coming from a pipe with a baffle on the back side of the HWT and if this is causing the issue. I couldn't find a screen or filter to clean. My furnace kicks on which leaves me to believe that it's not a fuel issue. Any advice would be truly appreciated. Thanks in Advance.
 
  #2  
Old 08-17-13, 07:49 PM
lawrosa's Avatar
Super Moderator
Join Date: Dec 2010
Location: Galivants Ferry SC USA
Posts: 15,993
Received 85 Upvotes on 77 Posts
Its under warranty... Your best off not touching it and call american water heater for service... Parts are covered... You just pay labor.... Should be minimal if just a hot surface /flame sensor failure.... Which it sounds like...
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: