A.O. Smith GPSH50 100 lighting issues


  #1  
Old 11-05-14, 08:17 AM
D
Member
Thread Starter
Join Date: Nov 2014
Location: USA
Posts: 1
Received 0 Votes on 0 Posts
A.O. Smith GPSH50 100 lighting issues

Seems there are no shortage of issues with this heater and the ignitor. I read through several of the threads and found similar issues to what I am experiencing but would like to confirm what I think to be the issue and how best to resolve. Water heater was installed in 2004 so I realize it is passed it's prime and should probably be replaced but money is tight right now so would like to try to squeeze the remaining life out of this thing!

Issue:Water heater cycles to ignite burner, fan kicks on, HSI glows, hear click for gas valve to open but no flame is ignited. Goes through this sequence 3 times then goes in to lockout mode with error code 6 ignition/flame failure (vacation led and A and B leds lit) indicated.

What I have tried:I have replaced the HSI and flame sensor, taken the fan and motor off the top of the unit and cleaned them out with compressed air. I find that if I blow into the burner cavity when I hear the click for the gas valve to open the burner will ignite otherwise the burner does not ignite and after cycling 3 times it locks out. I know this isn't the smartest thing to do:NO NO NO: but it gets the burner to light and produces hot water.

Question 1: Does this sound like the intellivent/gas valve has gone bad and needs to be replaced?

Question 2:I can purchase a new intellivent for around $300 but not sure I am up to replacing the unit myself. How difficult is this?
 
  #2  
Old 11-18-14, 04:16 PM
H
Member
Join Date: Nov 2014
Posts: 2
Received 0 Votes on 0 Posts
Igniter Going Out

Hi Everyone.
I think we are have same issue. First time I have written so not sure if I am doing this correctly.
We have an A.O.Smith and are having the same problem.
We received new Intelivent($$!) today made by White Rodgers. Wow. Not helping. Cleaned sensor and burner.
Checked vent outside.
Ran wire down side of tank.
Turns on. Blower comes on. Ignites for 3 seconds then shuts down. Cycles again.
What else?
We had a plumber out and he thought Intellivent.

Any ideas out there?
Thanks.
 
  #3  
Old 11-18-14, 04:19 PM
H
Member
Join Date: Nov 2014
Posts: 2
Received 0 Votes on 0 Posts
Igniter Going Out

Just to add, code is

Green Off Off Light Light Off
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: