Rudd power vent with power glow ignition


  #1  
Old 12-06-14, 09:31 AM
Y
Member
Thread Starter
Join Date: Dec 2014
Location: United States
Posts: 1
Upvotes: 0
Received 0 Upvotes on 0 Posts
Rudd power vent with power glow ignition

Ruud pvp40-1. Works often as designed but once in a while the power vent fan runs constantly. The igniter cycles on and off, the vacuum switch is functioning. Something is not allowing the gas valve to open? Most of the time if I unplug the unit and plug it back in the blower starts the igniter glows and then it lights. Not sure why sometimes it won't send gas on occasion? Any idea?

As I watch the burner heating the tank, for no apparent reason it goes out. The system cycles a few times and then everything quits except the blower.

I took the burner out and cleaned it. Made sure it was getting good air. Burns nice and blue.

It has a Robertshaw ignition module.

Have not located a limit switch.
 

Last edited by Yisit; 12-06-14 at 10:17 AM. Reason: Added info.
  #2  
Old 12-06-14, 11:20 AM
G
Member
Join Date: Oct 2002
Location: Hamilton County, Ohio
Posts: 3,927
Upvotes: 0
Received 2 Upvotes on 2 Posts
If your power vent motor has oil holes, be sure to give them a drop or two of light oil on a regular basis. A dry motor will lose some revs.
Remove the vacuum hose from the side of the blower housing and clean the inside of the nipple with a stiff pipe cleaner or a snug fitting drill bit (by hand). The vacuum switch is probably marginal on vacuum and this will cause the cycling you describe.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: